Mevo Cannot Connect to a Wi-Fi Network

If you have configured your Mevo to connect to the same Wi-Fi network your mobile device is connected to and the live edit view will not open, there are a few troubleshooting steps to try.

  • Hard close the app and relaunch. Sometimes a simple reopen will refresh the Bluetooth communication between the app and the camera.
  • Turn your mobile device's Bluetooth off, then turn it back on. Mevo uses Bluetooth to find nearby devices and check connection/usage status between the mobile device and the camera. If the Bluetooth signal gets interrupted, the communication between devices can fail. Restarting it has resolved this in the past.
  • Reboot the camera. Turn off the camera by holding down the power button, then turn it back on. When it finishes booting up, relaunch the app.
  • Test on another network. This will at least help narrow down whether the issue is with a specific Wi-Fi network or if it occurs with other networks.
    • If it works on one network and not another network, there may be configuration differences such as blocked firewall ports. If it's an Enterprise network, see here for setup.
    • If the failing network requires you to agree to their terms of use prior to using it (e.g. hotel network), this is called a captive portal, which is unfortunately not supported by Mevo.
  • Perform a hard reboot. Hold down the power button on top of the camera for about 15 seconds. Then power it back on. This article shows how to do this for each Mevo product.
  • Still having trouble? As a workaround, you can connect to your camera via the Mevo Hotspot. However, please contact us if you are still having difficulty connecting to your local Wi-Fi network.
Was this article helpful?
2 out of 3 found this helpful
Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.